Reports

How can I print text/graphics reports from analyses?

To print a report, select Print from the File menu (or press CTRL+P) to display the Print Report dialog. Use the options in the Print Range group box to specify what pages to print. To print the entire report, select the All option button. To print a range of pages, select the Pages option button and specify the range using the From and To boxes. To print the selected portion of the report, select the Selection option button. Then, click the OK button to print.

What is the difference between Rich Text Format (.RTF) and STATISTICA Report (.STR) format?

RTF (Rich Text Format) is a Microsoft standard method of encoding formatted text and graphics for easy transfer between applications. When reports are saved in Rich Text Format (*.rtf), all file formatting is preserved so that it can be read and interpreted by other RTF-compatible applications (e.g., Microsoft Word).

The STATISTICA Report format (.str) adheres to RTF conventions; however, saving reports in the default STATISTICA Report format (*.str) ensures that reports will be opened in STATISTICA, giving you complete access to the report tree. In order to open the report in an RTF-compatible application, select Save As from the File menu to save the report as an RTF file. You can then open it in any RTF-compatible application.

Can I combine text, tables, and graphs in one report?

Yes. You can use STATISTICA Reports to combine text and graphics. Create a new report (using the Create New Document dialog - Report tab, accessed by selecting New from the File menu), and then select the document you want to add to the report, and click the Add to Report toolbar button.

How do I adjust margins in the reports?

Use the options in the Print Preview dialog, accessible by selecting Print Preview from the File menu when the report is active or by clicking the Print Preview button on the toolbar.

report preview

You can position the desired text on the printed page by adjusting the margins (specify the Left, Right, Top, and Bottom margin widths, or drag the margin lines with the mouse pointer, as shown above). You can also create a header and footer for the document.

How can I automatically save to reports all spreadsheets and/or all graphs from an analysis?

In the Options dialog, select the Analyses/Graphs: Output Manager node. In the options pane, in the Report Output box, select either Send to Multiple Reports (one for each Analysis/Graph) or Single Report (common for all Analyses/Graphs). This will automatically generate a report(s) of all spreadsheets and graphs associated with your analyses.

Can I append output from multiple sessions to the same report?

To automatically send all results to the same report, select the Single Report (common for all Analyses/Graphs) in the Analyses/Graphs: Output Manager options pane of the Options dialog (accessible by selecting Options from the Tools menu). This automatically generates a report that contains all of the results and graphs created in STATISTICA (from the time the options are specified).

Can I save my reports in HTM format?

Yes. Select Save As from the File menu to display the Save As dialog. To save the file using an *.htm extension, select HTML Files (*.html, *.htm) from the Save as type option.

Items in the report are saved as *.png files in the same folder as the HTM file using the following naming convention: reportname_document type_0001.png, reportname_document type_0002.png, etc. You can save graphs as JPG files, instead. To do this, select Options from the Tools menu to display the Options dialog. Select the Reports node, and in the options pane, select the JPEG format option button in the Export HTML images as group box.

How do I create a new report?

To create a new report, select New from the File menu to display the Create New Document dialog. Select the Report tab and specify whether you want to create the report as part of a new Workbook or a stand-alone report. Alternatively, STATISTICA will create a new report for you (and add the active document to it) when you select New Report from the File - Add to Report submenu or from the Add to Report toolbar button.

Can I create a custom header or footer for my report?

Yes. You can create a customized header or footer for a STATISTICA Report (or any other document) that can include information such as the date, time, or the name and logo of your company. To create a header or footer, select Header/Footer from the View menu. This displays the Modify Header/Footer dialog in which you can select a default header or footer or create a custom header or footer.

Can I rename an item in a report?

Yes. When you add items to a report, they are inserted with generic document names (i.e., spreadsheet). However, you can rename report items (using a variety of Windows standard renaming conventions) so that they are more descriptive. For example, you can click to select an item in the report tree and press F2. Then enter the new name for the item and press ENTER.

Can I use drag-and-drop to rearrange items in the report tree?

Yes. The STATISTICA Report supports an entire range of drag-and-drop features within the report tree. Click on an item in the report tree, and drag that item to a new location within the tree.

Can I use clipboard functions to rearrange items in the report tree?

Yes. In addition to using drag-and-drop features to rearrange report items, you can use cut (CTRL+X), copy (CTRL+C), and paste (CTRL+V) functions to move items from one folder to another. To move (cut) a spreadsheet (or other document) in a report, right-click on the spreadsheet and select Cut from the shortcut menu (or press CTRL+X). This action places a copy of the item on the Clipboard while removing it from its current location in the report. To paste the spreadsheet into a new folder in the report, right-click the folder, and select Paste from the shortcut menu. Alternatively, you can press CTRL+V. This action places the spreadsheet (that you had cut to the Clipboard) in the desired folder in the report. Note that the pasted object is placed in the top position in the folder, and can be dragged to another position if desired.

What supplementary information is available with analyses and how can I add it to my reports?

STATISTICA provides a variety of supplementary information that can be included with graphs or spreadsheets from specific analyses when they are sent to a report. You can specify in the Analyses/Graphs: Output Manager options pane of the Options dialog (select Options from the Tools menu) how much information to include.

Displaying supplementary information. In the Supplementary detail box, you can select None or any of the commands described below:

  • Brief. Select Brief, the most "economical" output style, to include only the contents of the selected spreadsheets (i.e., no information about the variables or conditions specified for the analyses will be output).
  • Medium. Select the Medium output style to include the contents of the selected spreadsheets as well as the current datafile name, information on Case Selection Conditions and Case Weights (if any were specified), the Output Header, a list of all variables selected for each analysis, and the missing data values for each variable.
  • Long. Select the Long output style (which is more space consuming) to include all information from the Medium format and, additionally, the long variable names (e.g., labels, formulas), reserving one line of output (or more) for each variable.
  • Comprehensive. Select the Comprehensive output style to provide the most comprehensive information on each variable selected for analysis. In addition to all information included in the Long format, it also includes a complete list for each selected variable of all its values that have text label descriptions.
Content

Contact Us

StatSoft, Inc
2300 East 14th Street
Tulsa, Oklahoma, 74104
(918) 749-1119
info@statsoft.com