Workbooks

Can I add a folder to a workbook?

By default, when results are automatically added to a workbook, they are included in a folder that identifies from which analysis they originated; however, you can add as many folders (and levels) to a workbook as you want. This allows you to easily organize all of the items in your workbook, including spreadsheets, reports, and non-STATISTICA documents that are placed in the first level of the workbook by default. As with all items you can add to a workbook, folders can be inserted as either a sibling or a child to current workbook items.

Folders are added to the workbook tree via the Insert Workbook Item dialog. Right-click on the first folder in the workbook tree to display a shortcut menu, and select Insert to display this dialog.

workbook tree insert

You can also select Insert from the Workbook menu or press the INSERT key on your keyboard

When the Insert Workbook Item dialog is displayed, select the Workbook folder option button in the Item group box and As first child in the Placement group. Note that the sibling options in this box are disabled because we are adding an item to the root level of the workbook tree and it cannot have siblings. Click the OK button to add the folder to the workbook tree. Although folders can be added to any part of the workbook tree, this example adds a new folder to the first folder in the tree.

Note that when the folder is initially added to the tree, its name is selected. You can rename the folder at this time by entering a new name. To rename the folder later, double-click on the name New Folder, and enter a new name.

How do I add a document from another application to a workbook?

Documents from other applications (e.g., Excel spreadsheets, Word documents) are added to the tree via the Insert Workbook Item dialog. To display this dialog, select Insert from the Workbook menu. You can also right-click in the tree and select Insert from the workbook tree shortcut menu or press INSERT on your keyboard. The example below adds a new Word document as a child to the new folder created above.

Right-click on the New Folder and select Insert from the shortcut menu. Note that you can always move or copy the item to a new location later (using drag-and-drop features), so the exact location is not critical. In the Insert Workbook Item dialog, select the From another application option button in the Item group box and the As first child option button in the Placement group box. Then click the OK button to display the Insert Document from Another Application (e.g., Excel, Word, etc.) dialog.

You can insert either a new document or a previously saved document. For this example, select the Create New option button and select Microsoft Office Word Document in the Object Type group box. Note that if you do not have Microsoft Word installed on your computer, you can select any appropriate file type from this box. Finally, click the OK button to add the new document to your workbook.

How do I add a previously saved object to a workbook?

Previously saved ActiveX documents (e.g., STATISTICA Spreadsheets and Graphs, Excel spreadsheets, Word documents) are added to the tree via the Insert Workbook Item dialog. To display this dialog, select Insert from the Workbook menu. You can also right-click in the workbook tree and select Insert from the shortcut menu or press INSERT on your keyboard. You can add a variety of file types to a workbook, a feature that assists you to easily organize all of the files associated with an analysis. As with all items you can add to a workbook, files can be inserted as a sibling or as a child to current workbook items.

Follow these steps to add a previously saved file as the next sibling to the first item in the current workbook:

Select the first item in the current workbook, and then display the Insert Workbook Item dialog by selecting Insert from the Workbook menu. In the Item group box, select either the STATISTICA Document option button or the From another application option button, and in the Placement group, select the As next sibling option button. Click the OK button. If STATISTICA Document was selected, the Document type dialog will be displayed. If From another application was selected, the Insert Document from Another Application dialog will be displayed.

In either dialog, select the Create from File option button and then click the Browse button to display the Browse dialog, where you can locate the file you want to insert into the workbook.

How do I add the current item to a workbook?

You can add any STATISTICA object to a workbook including graphs, reports, macros, and spreadsheets. The most direct way to add the current STATISTICA object (i.e., the document that currently has focus) to a workbook is to click the Add to Workbook toolbar button. A list of currently available workbooks is displayed, allowing you to select in which workbook to include the item.

workbook add

You can also add the item to a new workbook.

By default, the item is appended at the end of the workbook tree one level below the root node (i.e., it is not placed as a sibling to any existing items in the workbook). You can relocate the object using the workbook's drag-and-drop facilities.

You can also add currently open STATISTICA documents to the workbook using the Insert command from either the Workbook menu or the workbook tree shortcut menu. Select Insert to display the Insert Workbook Item dialog, and then select the STATISTICA Document option button in the Item group box. Click the OK button in the Insert Workbook Item dialog to display the Document type dialog.

workbook document type window

In this dialog, select the Create from window option button and specify which document to add using the Window box. Click the OK button to add the selected document to your workbook. Note that if you want to add all open STATISTICA documents to your workbook, select the All Windows option button in the Insert Workbook Item dialog, and then click the OK button.

You can also add currently open ActiveX documents (e.g., Word documents or Excel files) to your workbook using the Clipboard. To add an open Word document, select the entire document (or a portion of it), copy it to the Clipboard (press CTRL+C), and then paste the contents of the Clipboard into the workbook (press CTRL+V or select Paste from the Workbook menu). STATISTICA automatically creates the appropriate type of document in the workbook and includes the contents of the Clipboard in that document.

How do I add a saved STATISTICA document to a workbook?

You can add a saved STATISTICA document to your workbook (e.g., a spreadsheet, graph, report, or macro) by selecting Insert from the Workbook menu or workbook tree shortcut menu.

For example, to add the Adstudy.sta sample data file to the current workbook, open a workbook and click on any item in the workbook tree. Now, press the INSERT key on your keyboard to display the Insert Workbook Item dialog. (You could also select Insert from the Workbook menu or the workbook tree shortcut menu to display this dialog.)

In the Insert Workbook Item dialog, select the STATISTICA Document option button in the Item group box and the As next sibling option button in the Placement group box. Click the OK button to display the Document type dialog.

workbook document type file

Select the Create from file option button in the Document type dialog, and then click the Browse button to display the Browse dialog. Adstudy.sta is located in the Examples/Datasets subfolder of your STATISTICA installation folder. Double-click on the file to enter it into the File box on the Document type dialog (as shown above). Click the OK button to add the file to your workbook.

How do I add a new STATISTICA document to a workbook?

In addition to adding current and previously saved STATISTICA documents to a workbook, you can also add new (blank) documents to a workbook, including spreadsheets, reports, and macros. When the new document is added, you must specify where to place the item in the workbook tree (as either a sibling or child to another item in the workbook) and which type of item to create.

One way to add a new STATISTICA document is to determine an appropriate location in the workbook tree and right-click another item in that location. You can always move or copy the item to a new location later using drag-and-drop features, so the exact location is not critical.

From the workbook tree shortcut menu, select Insert to display the Insert Workbook Item dialog. Select the STATISTICA Document option button in the Item group box and the tree location (either As last child, As first child, As next sibling, or As prior sibling) option button in the Placement group box. Click the OK button to display the Document type dialog.

workbook document type new

Use this dialog to create a new document, locate a previously saved document, or select an open document. For this example, select the Create new option button and select a spreadsheet, report, or macro in the Type box. Then, click the OK button to add the new document to your workbook.

How do I delete items from a workbook?

Commands for deleting workbook items are available from the Workbook menu, as well as from the workbook tree shortcut menu (accessed by right-clicking in the workbook tree). You can also delete an item by selecting it and pressing the DELETE key on your keyboard. Note that when you delete an item that has children, all of its children will also be deleted.

How do I rename workbook items?

Commands for renaming workbook items are available from the Workbook menu as well as from the workbook tree shortcut menu (accessibly by right-clicking in the workbook tree). You can also select a workbook item and press F2.

Can I rearrange the workbook tree with drag-and-drop?

Yes. The STATISTICA Workbook supports an entire range of drag-and-drop features within the workbook tree. Click on an item in the workbook tree, and drag that item to a new location within the tree. In fact, since the drag-and-drop features support parent/child relationships, you can use these features to rearrange large portions of the workbook tree.

To select the parent node and all of its children, simply click on the parent node (or press CTRL while clicking on the parent node and each of its children). To make discontinuous selections (i.e., select some of the children, but not all of them), hold down the CTRL key while clicking on each item you want to select. You can also make discontinuous selections across nodes using the CTRL key.

Follow these steps to move a folder (and its contents) to a new location in the workbook tree:

1. Click on the folder to select it and all of its children.

2. Right-click on the folder and drag the folder to a new location in the tree.

3. Release the right mouse button, and a shortcut menu is displayed, giving you options to either copy or move the dragged item. You can place the item before, after, or as a child to the newly selected item in the tree.

How do I use copy and paste in a workbook?

In addition to using drag-and-drop features to rearrange workbook items, you can use the Copy and Paste commands. Commands for cutting, copying, and pasting are available from the Workbook menu, the workbook tree shortcut menu, and the Standard toolbar.

Can I select discontinuous items in the workbook tree?

You can select one or more items in the workbook tree using the standard Windows SHIFT+click and CTRL+click conventions to select ranges and discontinuous lists of variables, respectively. Additionally, you can select and deselect tree items using the keyboard navigation keys (e.g., HOME, END, PAGE UP, PAGE DOWN, and arrow keys). You can delete an entire selection by pressing the DELETE key. Press the INSERT key to display the Insert Workbook Item dialog for the currently selected item.

Note that to select discontinuous items of a particular node, you will need to expand the node (by clicking on the plus sign adjacent to the node).

Can I print more than one item from a workbook without printing the entire workbook?

Yes. When printing from within a workbook, only the currently displayed (active) item is printed when the Print button is clicked, but if the Print dialog is used, multiple selections from the workbook can be printed by using the Selection option in the Print Workbook dialog. Note that STATISTICA supports the standard Windows SHIFT+click and CTRL+click conventions to select ranges and discontinuous lists of items, respectively. Thus to print a range of graphs from a workbook, select the range of graphs, select Print from the File menu to display the Print Workbook dialog, select the Selection option button in that dialog, and click the OK button.

How do I view the multi-item display in a workbook?

Click on a folder in the left pane of a workbook that contains spreadsheets, graphs, or other documents to view the display.

Can I specify a certain number of columns for a multi-item display?

To set the global default for all future workbooks, from the Tools menu select Options to display the Options dialog, and select Documents: Workbooks. In the options pane, you can change the defaults for the number of columns as well as the height and width of the items in the display (see the options in the Multi-Item Display group box).

Can I change the multi-item display settings in a workbook I have already created without changing the global defaults?

Yes. With the workbook open, from the Workbook - Multi-Item Display submenu, select Settings to display the Multi-Item Display Settings dialog. Alternatively, you can right-click on a folder in the workbook and select Multi-Item Display - Settings to display the Multi-Item Display Settings dialog. Select the Apply to All Folders check box if you want the changes to apply to all folders currently in your workbook. Otherwise, the changes will apply only to the selected folder. Different folders in a workbook can have different multi-item display settings.

Can I specify that all future folders in a certain workbook have a specific number of columns in the multi-item display without changing the global defaults?

Yes, you can change the defaults just for one specific workbook. With that workbook open, select Default Settings from the Workbook - Multi-Item Display submenu to display the Multi-Item Display Settings dialog where you can make changes. Alternatively, you can right click on any folder or item in the workbook and select Multi-Item Display - Default Settings from the shortcut menu to display Multi-Item Display Settings. Select the Apply to all folders check box.

How can I make changes to a graph or spreadsheet in my multi-item display?

There are two ways to do this. If you make changes to the graph or spreadsheet in your workbook, the changes will be reflected automatically in the display item. You can also double-click on an item in the display to "in-place activate" it, and make changes directly in the multi-item display. When an item is in-place activated and modified, changes to the item will be reflected in the corresponding workbook item it represents.

Can I rearrange the order of the items in the multi-item display?

Yes. In the workbook tree view, simply click and drag the item to a new location. The display will be updated automatically according to the new order in the tree view.

Can I print the multi-item display?

Yes. Print the display by selecting Print Active Item from the File menu.

Content

Contact Us

StatSoft, Inc
2300 East 14th Street
Tulsa, Oklahoma, 74104
(918) 749-1119
info@statsoft.com